
What is SuperQueue?
SuperQueue provides substantial enhancements to the Windows 95 print spool viewer. In addition to a more 
complete view of the print queue, SuperQueue offers important new functionality such as:

Direct support through external filters for file types other than Windows 95 Enhanced Metafiles (EMF), text,
and “raw” printer data files. SuperQueue can print these added printer file types directly, without the need for the 
originating application. Additional filters can be installed at any time.

Screen preview (with zoom) for filter-supported files.
Clipboard cut and paste for filter-supported files.
Support for simultaneous printing on multiple devices.
Added control over the print job queue.
Job status and tracking information.



SuperQueue quick tour
The SuperQueue window is similar to that of    the Windows 95 Printers folder. Each installed printer is 
represented by a child window, which we call a printer window. SuperQueue’s printer windows contain both the 
list of jobs (the queue) and messages from SuperQueue’s translation filters. Unlike Windows’ Printers utility, the 
individual printer windows in SuperQueue cannot stand alone as separate windows — they are always linked to 
and contained within SuperQueue’s main window.
Note that most choices you make using either the tool bar or the menus apply only to the currently selected 
printer. The title bar of the current printer window is highlighted and the name of the current printer normally 
appears in the status bar at the bottom of the SuperQueue window.
The invisible parts of SuperQueue are the print processing filters. Filters work in the background to translate 
native format files (bitmaps such as TIFF and BMP, plus PostScript language files) into Windows’ “native 
language” (GDI).



How to hide and restore the Tool Bar
To hide the tool bar:

In the View menu, uncheck Tool Bar by choosing it.
If the tool bar is hidden and you want to restore it:

In the View menu, check Tool Bar by choosing it.



Status Bar basics
The status bar runs along the bottom edge of the SuperQueue window. On the left side, one of two things is 
displayed

If the cursor is directly over an active tool bar button or if an active menu choice is highlighted, the 
function of that choice is described, or,

If the cursor is elsewhere, the currently selected printer is indicated.
Printer-specific choices you make using either the tool bar or the menus apply only to the printer shown.
On the right side of the status bar, the state of the currently selected printer is shown (Ready or  Paused) and 
the number of documents in the queue is displayed.



How to hide and restore the Status Bar
To hide the status bar:

In the View menu, uncheck Status Bar by choosing it.
If the status bar is hidden and you want to restore it:

In the View menu, check Status Bar by choosing it.



Printer Properties
The Properties selection in the SuperQueue Printer menu is a convenient location for choosing many Windows 
printing options. The descriptions of these options are listed according to the tabs in which they appear:
General tab    Includes information about Separator pages.

Details tab    Includes information about Spool and Port Settings.

Sharing tab/Windows 3.11    Provides information about sharing printers.

Advanced tab/Windows 3.11    Describes options such as printer availability and printing to available ports.



General tab, Printer Properties
n Comment

This text box provides a place for you to add a comment about the printer; for example, when it is available or 
what it is used for. If you share this printer, the comment is transferred when someone sets up your printer on 
their computer. However, if you change the comment, other people will not see the updated version.

n Separator page
This text box allows you to specify a file that is sent to the printer before printing each document. This is 
useful if many people are using your printer or if you are printing multiple documents at once. You can choose 
either a fill page that includes graphics or a simple page with text only.
If you want to use a custom separator page, click Browse to locate and specify which separator file you want 
to print. You can set up separator pages only if the printer is attached directly to your computer.

n Browse
Allows you to look for and specify a file that you want to use as a separator page. 



Details tab, Printer Properties
n Print to the following port

This listbox displays the port your printer is connected to or the path to the network printer you are using. You 
can change where you print to by typing the network path here, by opening the list and clicking a port, or by 
clicking Add Port.

n Print using the following driver
This listbox displays the type of printer you are using. This type must match your printer or be one that your 
printer can emulate.

n Add Port button
Allows you to add a new port or specify a new network path.

n Delete Port button
Allows you to delete a port from the list of available ports.

n New Driver button
Update or change your printer driver. Not implemented at this time.

n Timeout settings
Not Selected specifies now much time (in seconds) Windows will wait for the printer to be online before 
reporting an error.
Transmission retry specifies how much time (in seconds) Windows will wait for the printer to be ready to 
print before reporting an error. If you have problems printing large documents, you may want to increase the 
value of this setting.

n Setup button
Click to change settings specific to your printer.

n Spool Settings
Opens a dialog that allows you to set spooling choices.
Spool print jobs so program finishes printing faster. Use this setting to Queue print jobs.
Start printing after last / first page... SuperDrivers start printing after the last page is spooled regardless 
of which setting is chosen.
Print directly to the printer. Use this setting to Unqueue print jobs.
Spool data format
Specifies the format in which to store printing information on your disk while a print job is waiting to be 
printed. Under normal circumstances, if you are using a SuperDriver, you should leave this option set at SMF 
(SuperMetafile). Generally, SMF format frees up your program faster because it is smaller and doesn't depend 
on what kind of printer you have. RAW format is specific to the printer, so extra time may be required to 
convert the printing information, and your program would not be available for working on other tasks.
Enable / Disable bi-directional support
Applies only to printers that have bi-directional capabilities. Bi-directional support must be disabled to print to 
two different ports at the same time.

n Port Settings
Click the Port Settings button to open a dialog that allows you to specify whether you want to spool 
documents that you print from MS-DOS-based programs. There is also an option to check the port state before 
printing. 



Sharing tab, Printer Properties

Windows for Workgroups 3.11 only
n Share the Printer on the Network

To share the printer named at the top of the dialog, choose the Share the Printer on the Network 
checkbox.

n Share Name
Use the Share Name text box to specify the name of the shared printer.

n Location
Use the Location text box to include a description of the printer’s location.



Advanced tab, Printer Properties

Windows for Workgroups 3.11 only
n Available From/To

To set the hours during which the printer prints documents, set a starting time in the Available From box and 
an ending time in the To box.

n Priority
Allows you to set the priority of the printer. All documents on a higher priority printer print before documents 
on a lower priority printer, regardless of the individual document properties.

n Print Processor
The Print Processor default is set to SuperQueue95. In general, you should not need to change it. However, 
some specialized applications may require a different print processor.

n Print to Additional Ports
Allows you to group several printers into a pool. The first available printer prints a document sent to the pool. 
To create a printer pool, select the ports that correspond to the ports where you have connected printers.



Printer windows overview
SuperQueue’s multiple window interface makes it possible to monitor the activity of each printer on your system.
Each installed printer is represented by a window that displays a job list (or queue) for that printer. Multiple 
queues can operate simultaneously, one for each printer. Note that if job processing is underway, even if you 
minimize a printer window or close SuperQueue, the processing will continue in the background.
Each printer window is divided into two main sections: the queue area and the message area. The first time you 
open a new printer window, each area takes up half the window. If you change the arrangement of the windows 
or the queue/message areas of a window, SuperQueue remembers the changes for subsequent sessions.
At the bottom of each window is a status bar. This displays the progress of filter translations and also lets you 
know if any messages have appeared in the messages portion of the printer window.

Related Topics



How to configure the queue and message areas
Each printer window displays a job list (or queue) for that printer plus a message section for information 
generated by the filters.
If only the queue is visible, make the message area visible as follows:
    Choose Messages from the View menu, or;
    Click on the dividing bar at the bottom of the queue area and drag it up.
If only the message area is visible, make the queue visible as follows:
    Choose Queue from the View menu, or;
    Click on the dividing bar at the top of the message area and drag it down.
In each case, the latter method lets you determine how much screen space you want to give to the queue area 
vs. the message area. The View menu selections force the entire printer window to be devoted to that choice.
If the printer window is currently divided, showing both the queue and message areas (the default), both the 
Queue and Messages choices will be available on the View menu.

Related Topics



How to change the screen font
The font that’s used to display queue and message information can be changed as follows:
1. Choose Fonts... from the Options menu.
The Font dialog appears.
2. Make choices from the Font, Font Style, and Size list boxes.
A sample of your choice appears in the Sample box.
3. When you’re finished, choose OK.



How to automatically arrange printer windows
SuperQueue’s printer windows conform to the Windows standard Multiple Document Interface (MDI).

To automatically arrange all open windows so they overlap with their title bars showing, choose Cascade 
from the Window menu.

To automatically arrange all open windows as non-overlapping tiles, choose Tile from the Window menu.
To automatically arrange all minimized printer windows, choose Arrange Icons from the Window menu.



Reading the queue information
There are six pieces of information displayed for each job in the queue: the document’s name, status, owner, 
and progress, the date and time the job was added to the queue, and the job’s data type. The bar across the top 
of the queue area controls the width of each field; by dragging the dividing bar, the width of a field can be 
changed.
The format of the information in the Document Name column changes depending on several factors. If the job 
was submitted by a Windows application, it typically begins with the name of the application followed by the 
document name. If the job is a bitmap file that was loaded using Printer/Add Documents… (or drag-and-drop),
it typically shows the file’s directory and filename. If the job is a PostScript file which contains title information (in
the form of a “%%Title” remark), that information is shown under Document Name. The implementation of the 
title remark in PostScript files varies widely by application.
Status displays Spooling while a job is being submitted by an application, Printing while the job is being sent 
to the printer, and Deleting if the job is being removed from the queue. In addition, if an individual job has been
put on hold, the Status column shows Paused.
When printing on a network, the Owner column shows the network names of the client users who generated the
files. On a standalone system, this column is blank. If you are on a standalone system, you may want to 
“collapse” the owner column to give more room to the other columns. To do this, drag the dividing bar on the 
right of the word Owner all the way to dividing bar on the left.
While a job is printing, Progress shows the sequence of job processing either in pages or in byte counts. For 
jobs waiting in the queue, the total number of pages or byte counts are displayed. 
The date and time at which the job arrived in the queue is shown under Started At.
The last column shows the Data Type. Windows 95 (without SuperPrint) handles two basic data types: EMF 
(Enhanced MetaFile) and RAW (low-level printer data). SuperQueue’s filters and print processors allow for many 
additional data types including:
SMF (SuperMetaFile)
PS (PostScript)
BMP (Windows BitMaP)
TIF (Tagged Image File Format)
GIF (Graphics Interchange Format)
JPG (Joint Photographic Experts Group)
As filters are added to SuperQueue, additional data types may be used.

Related Topics



How to change job priority with the mouse
When you have several jobs waiting in the print queue, you can re-order (change the priority) of the jobs easily 
with the mouse using drag and drop.
1. Click on the job’s listing in the Document Name column.
2. Drag the job up or down to its new location.
If you are dragging a job up (promoting the job), the job will be inserted above the job onto which you drop it; if 
you are dragging a job downwards (demoting a job), the moved job will appear below the job onto which you 
drop it.

Related Topics



How to change job priority with menus or buttons
With the job’s listing in the Document Name column highlighted:
    Move the job one place at a time with the Document menu choices or the tool bar buttons called Promote 

Document (to move it up) or Demote Document (to move it down).
    Move the job to the top or bottom of the queue with the Document menu choices Move To Front or Move To 

Back.
Note that moving a job in front of the currently printing job in the queue will not cause the new    “top” job to 
interrupt the currently printing job. If you must print the new job right away, you need to drag it to the number 
two position, then delete the currently printing job using the DEL key or Remove Document.

Related Topics



How to remove a single job from the queue
1. Highlight the job’s listing in the Document Name column.
2. Press the DEL key.
Alternatively, you can either choose Remove Document from the Document menu, or click on the Remove 
Document button on the tool bar.



How to remove all jobs from the queue
    To clear the queue of all jobs, choose Purge Printer from the Printer menu.
If a job is in progress, it will be terminated. A dialog appears asking you to confirm this choice.
Jobs created by printing from a Windows application are removed from the queue and deleted from disk. Jobs 
added using Add Document or drag-and-drop are removed from the queue, but the original files remain on the 
disk. 



Document (Job) Handling
The terms “document” and “print job” are interchangeable. Each line in the print queue represents one 
document.
Documents can be generated by printing from Windows applications or they can be in the form of data files 
(such as TIFF or PostScript). When spooling is on, documents from Windows applications are added to the queue 
automatically. Data file documents are added using Add Documents from the Printer menu or tool bar, or 
using the “drag and drop” method.
SuperQueue can load and print files in various formats. The acceptable file extensions are determined by the 
filter itself. Some filters designate more than one extension, so if you have chosen a particular extension in the 
Files of Type list box, you may need make another choice or choose All SuperQueue data types to find the 
correct one. If your file is of the correct data type but uses an extension other than the ones supported by the 
filter, you can either enter a wildcard (for example, *.PRN) in the File name box of the Add Documents dialog, 
or change your file's extension using Windows Explorer.

Related Topics



How to add a job using Add Documents
1. Choose Add Documents from the Printer menu or click the corresponding button on the tool bar.
The Add Documents dialog appears.
1. Choose the desired format from the Files of Type list box (optional).
By default, the Files of Type box shows All SuperQueue data types. If you have many diverse file types in 
the current directory, you can narrow the search to a particular file extension using this feature.
3. Navigate to the drive and folder that contains your file.
4. Choose your file and click Add.
If you add a file that SuperQueue does not recognize, it will present a Manual Filter Selection dialog. You must
then manually choose the filter to be used for this job.

Related Topics



How to add a job using drag and drop:
1. Locate the data file listing using either Windows Explorer or My Computer.
2. Drag the file listing onto the desired printer window within the SuperQueue window.
Note that you can drag a data file onto a minimized printer window (a “brick”) within SuperQueue. However, you 
cannot drag a file onto the task bar if the SuperQueue window is minimized.
If you drag and drop a file that SuperQueue does not recognize, it will present a Manual Filter Selection 
dialog. You must then manually choose the filter to be used for this job.

Related Topics



Filter messages
The lower part of a SuperQueue printer window provides messages only for jobs that are processed through a 
SuperQueue filter. This includes SuperMetafiles that are generated when printing from Windows applications. It 
does not include NT Journal files. Messages typically include the start and finish times for job processing and the 
total elapsed time with a page count. Other messages may include warnings generated by the filters (these 
typically do not stop printing) and filter errors (which may stop printing).
To keep a record of filter messages for all printers, enable Message Logging in the Options menu before 
printing. A separate log file for each printer is created in the temporary folder on your hard disk.The log file is 
cumulative from one session to the next so long as Message Logging is active. To view the message log for the
active printer, select the port tab (such as LPT1:) and choose Log File in the View menu. This option will be 
grayed and unavailable if there are no messages or if you have not selected a port tab.
After having created a log file, if you subsequently disable Message Logging, a message box will be displayed 
asking if you wish to delete all existing message log files. If you say yes, all of the logs for all of your printers will 
be deleted.
If Message Logging is not enabled, filter messages will accumulate in the message area of the printer window 
over the course of the current session, but when you close SuperQueue, all unsaved messages are lost. If you 
start SuperQueue while a filter job is printing, messages for that job will not appear.
Edit menu
All choices on the Edit menu are grayed (as are their tool bar equivalents) unless Windows’ focus is on the 
message area of the current printer window and the message area contains some text. The focus is most easily 
recognized by a flashing text cursor. Focus can be transferred to the message area by either clicking on the 
appropriate port tab or by clicking within the message text itself.

Related Topics



How to choose a message tab
SuperQueue “sorts” messages according to the print job’s destination. Typically, there are two tabs at the bottom
of the message area: one marked “Preview Messages” and one marked with either the port designation of your 
local printer (typically LPT1) or the network address of a remote printer.
    To see the activity associated with screen preview or local processing of a network job when Options/Remote 

Processing is off, click on the Preview Messages tab.
    To see the activity associated with local printing or printing a network job with Options/Remote Processing 

on, click on the appropriate port tab.



How to copy messages onto the clipboard
The contents of the message window can be copied, in whole or in part, onto the Windows clipboard for pasting 
into other applications (typically text editors).
To copy only a portion of the text:
1. Choose the tab that corresponds to the target destination (preview or port).
2. Highlight the text you want to save
3. Choose Copy from the Edit menu (or click the Copy button on the tool bar)
To copy all of the message text:
1. Choose the tab that corresponds to the target destination (preview or port).
2. Even if the correct tab is on top, this action is necessary to put the “focus” on the message area.
3. Choose Select All from the Edit menu.
4, Choose Copy from the Edit menu.



How to find text in the message area
SuperQueue lets you locate particular words or phrases in the messages portion of the printer window. For 
example, this procedure makes it possible to locate all occurrences of    “BMP.”
1. Choose the tab that corresponds to the target destination (preview or port).
Even if the correct tab is on top, this action is necessary to put the “focus” on the message area.
2. Choose Find… from the Edit menu.
3. Enter the desired word or phrase in the Find what: box and click Find Next.
Clicking on Find Next repeatedly will cause SuperQueue to find additional occurrences of the search string.



How to clear the contents of the message area
1. Choose the tab that corresponds to the target destination (preview or port).
Even if the correct tab is on top, this action is necessary to put the “focus” on the message area.
2. Choose Clear All from the Edit menu.



How to preview a document
1. Choose Add Document from the Printer menu.
2. Check the box next to Hold document(s) (for Preview.) if necessary).
3. Choose the desired format from the Files of Type list box (optional – the default is All SuperQueue data 

types).
4. Navigate to the drive and folder that contains your file.
5. Choose your file and click Add.
6. Highlight the name of the job in the queue window.
7. Choose Print Preview... from the Document menu.
During processing by the appropriate filter, a Print Preview status dialog appears. When processing is finished, 
the preview window appears. It defaults to a single-page, “fit to window” mode. You can resize the preview 
window and the preview page will expand accordingly.

Related Topics



# Adding_multiple_jobs $ Adding multiple jobs K Adding multiple jobs + SQ95:0 Adding multiple jobs
If you’ve added multiple jobs, a Configure Filter dialog appears. You have these options:
•    Modify filter settings for this file – SuperQueue presents the Filter Preferences dialog for this job, then 
redisplays this Configure Filter dialog for the following job.
•    Accept default filter settings for this file – SuperQueue applies the filter defaults to the current job and 
redisplays the Configure Filter dialog for the following job.
•    Accept default settings for all remaining files – SuperQueue adds all the selected documents using filter 
defaults with no further prompts.



Preview window features
At the top of the preview window is a row of buttons that give you access to several functions.
All previewed jobs can take advantage of    Zoom In and Zoom Out. Aside from the fit to window view, there are
two zoom levels. If you are zoomed in all the way, the Zoom In button will gray. Similarly, Zoom Out is grayed 
when you are in fit to window mode. Note that the mouse cursor can be used to zoom in as well. The zoomed 
view is centered over where you click.
Multi-page jobs can take advantage of    Next Page, Previous Page, and Two Page. As you might expect, Next
Page and Previous Page let you scroll through your job a page at a time. Two Page gives you a side-by-side 
view of two pages at once.
Copy places a Windows metafile copy of your artwork on the Windows Clipboard. You can then paste the artwork
into other Windows applications. Programs that have an “ungroup” function (such as CorelDRAW) can be used to 
modify the artwork if you want. For multi-page jobs, the currently displaying page is the only one placed on the 
clipboard.
Save gives you a chance to save the metafile in either EMF (Windows 95 Enhances Metafile) or WMF (older-style 
Windows Metafile) format. Your choice of formats may depend on the application into which you want to import 
the artwork.
Close returns you to the SuperQueue main window. You cannot view the main SuperQueue window and the 
preview window simultaneously.

Related Topics



How to hold and release a document
Putting a document on hold may be useful if, for example, you have an exceptionally long or complex document 
that you want to process at a later, presumably less busy time. To hold a document:
1. Highlight the job’s listing in the Document Name column.
2. Choose Hold Document from the Document menu.
A pause symbol appears next to the listing and “Paused” appears in the Status column.
To release a paused job:
1. Highlight the paused job’s listing in the Document Name column.
2. Choose Release Document from the Document menu.



Document Properties
The first page, General, displays all the information that SuperQueue knows about the document. Most of these 
attributes are self-evident. Note that Owner and Queued From contain network related information; they will 
be blank for standalone systems.
Select the Job Properties (PostScript filter) or Print (bitmap filter) tab to open the second page. It gives you 
access to change the filter options for the currently selected document. This is a convenient place to change 
options if you have previously    requested that the Filter Properties dialog not be displayed when you add a 
document..
If the currently selected document is a bitmap, an Image Info tab will give you basic information about the 
document. If the bitmap is either an 8-bit grayscale or 24-bit color image, you will also be presented with an 
Enhancement tab.

Related Topics



Document Properties Help
The first page, General, displays all the information that SuperQueue knows about the document. Most of these 
attributes are self-evident. Note that Owner and Queued From contain network related information; they will 
be blank for standalone systems.
Select the Job Properties or Print tab to open the second page. It gives you access to change the filter options 
for the currently selected document. This is a convenient place to change options if you have previously    
requested that the Filter Properties dialog not be displayed when you add a filter.
If the currently selected document is a bitmap, an Image Info tab will give you basic information about the 
document. If the bitmap is either an 8-bit grayscale or 24-bit color image, you will also be presented with an 
Enhancement tab. 



How to pause and restart a printer
To pause a printer:
1. Make sure the printer window that represents the printer you want to pause is active.
2. Choose Pause Printer from the Printer menu.
Pause Printer puts the selected printer queue “on hold” – incoming print jobs accumulate but are not processed
until Start Printer is chosen.    
To restart a printer:
1. Make sure the printer window that represents the printer you want to start is active.
2. Choose Start Printer from the Printer menu.

Related Topics



Pausing the printer
If Pause Printer is chosen while a job is in progress, SuperQueue temporarily stops processing that job. Printing 
resumes where it left off when you choose Start Printer. Note that on certain printers, a long pause in a data 
stream can be interpreted as a time-out which may cause the printer to eject a partially printed page. 
Subsequent resumption of the data stream can also cause printing problems if the printer is expecting “header” 
information to begin a new page; the mid-page data may be misinterpreted.

Related Topics



How to set a printer as the default
The Windows default printer is the one to which applications normally print (without specific action on your part 
to choose another printer). SuperQueue makes it easy to set the default printer.
1. Make sure the printer window that represents the printer you want to make the default is active.
2. Choose Set as Default Printer from the Printer menu, or click on the corresponding button on the tool bar.
Note that when the current printer is the default, there’s a check mark next to Set as Default Printer in the 
Printer menu, and the corresponding tool bar button appears to be depressed.



How to add a filter
Filters are the program modules that allow SuperQueue to accept native data file formats such as TIFF and 
PostScript. Filters that come with SuperPrint are installed automatically when you run SuperPrint’s Setup 
program. If you’ve removed a filter and want to re-install it, or if you have acquired a new filter and have already
copied it to your hard disk,    proceed as follows:
1. Choose Filter Libraries... from the Options menu.
The Manage Filter Libraries dialog appears.
2. Choose the Install... button.
The Install SuperQueue Filter Libraries dialog appears.
3. Navigate to the drive and folder containing the SQF file.
4. Highlight the desired filter and click OK.
Note that installing a filter requires that you restart Windows 95 to cause the change to take effect.

Related Topics



How to configure a filter for automatic operation
1. Choose Filter Libraries... from the Options menu.
The Manage Filter Libraries dialog appears. 
2. Highlight the filter’s listing in the Installed Filter Libraries box.
3. Choose the Setup... button.
Each filter has different options, so dialogs will vary.
One common feature is called Ask for preferences each job. If checked, a setup dialog appears each time you
start processing a job with this filter. If the check box is cleared, the features you set here automatically apply to 
all jobs.
4, When all options are set, click OK.

Related Topics



How to remove a filter
If you believe you will have no further use for a particular filter, you can remove it from the filter list.
1. Highlight the doomed filter in the Installed Filter Libraries list box.
2. Click the Remove button.
The chosen filter is removed from the list, but its files are not erased from disk. This allows you to re-install the 
filter later.
Note that removing a filter requires that you restart Windows 95 to cause the change to take effect.



Filter Libraries
Options/Filter Libraries... brings up the Manage Filter Libraries dialog. At the top is a list of currently 
installed filters. When you highlight a filter, the function of that filter, along with its supported file extensions, is 
shown in the Library Contents (Filters) box. 
The Remove button allows you to remove a filter already installed. The Install button allows you to install a new
filter or replace a filter you have previously removed.
The Setup button accesses the filter preferences dialog, where you can set various options for the selected filter.
The About button brings up an informational dialog regarding the currently chosen filter. Included are the names
of some very talented programmers and the version number, the latter being useful if you should need to 
contact Zenographics for technical support.

Related Topics



Filter preferences
Each document can have its own set of Filter Preferences. There are three places in which you can specify 
them:
Set filter preferences in advance in the Manage Filter Libraries dialog. 
Choose Filter Libraries from the Options menu. Make a filter selection and then click the Setup button in the 
Manage Filter Libraries dialog. Note that each filter has different options, so dialogs will vary. One common 
feature is called Ask for preferences each job. If checked, a setup dialog appears each time you start 
processing a job with this filter. If the check box is cleared, the features you set here automatically apply to all 
jobs.
Set filter preferences when you add a document. 
If you haven’t turned off Ask for preferences each job, you can set the preferences in the pop-up dialog that 
appears when you add the job. If you click Cancel from the Filter Preferences pop-up dialog, the job is not 
added to the queue. If the settings that appear in the pop-up dialog are correct, and if you expect that they will 
not need to be changed, you may want to check Don’t display these options again. 
Set filter preferences in Document Properties. 
If the pop-up did not appear when you added a document, or if you want to change the settings after adding a 
job to the queue, you can set filter preferences using Document Properties for any job that’s not currently 
being printed.

Related Topics



Ask for preferences each job
When you access the filter options using Options/Filter Libraries…/Setup in SuperQueue, each filter has a 
choice called Ask for preferences each job. If Ask for preferences each job is on, the other settings you 
choose here become the defaults, but you are given an opportunity to override these settings on a per-job basis. 
With Ask for preferences each job off, the settings are applied automatically to each filter job. They can still 
be overridden using Document Properties.
Use of this option depends on how you use the filter. If, for example, you are imaging slides from TIFF files, and 
you always want to fill the slide frame with the selected image, you'll probably want to choose Fit to page and 
clear the Ask for preferences each job check box. This will prevent SuperQueue from asking you for these 
options at the beginning of each job.

Related Topics



Bitmap filter specifications

When you add a document, or change options using the Document Properties dialog,    the Print tab includes 
the name of the current printer and a Properties button that opens the standard printer properties dialog. This 
lets you set things like paper size and resolution on a per-job basis.

Number of copies
You are allowed to set multiple copies for the current document. 
Print to file
When checked, this option will send the printer data to a file. For output devices set to print to a port, this will 
force the printer data to be sent to a file instead. For devices already set to FILE:, the Print to file checkbox is 
redundant. 
Image size and position
Filters that translate bitmap file formats (such as TIFF, BMP, GIF, and JPEG) generally offer several common 
options (see screen capture for typical settings). 
Turning Stretch to fit page on causes the filter to size the bitmap until either a maximum height or width 
printable area boundary is reached. For example, if you are printing a square bitmap on a portrait page, the filter
will encounter the maximum horizontal printable area limit before it reaches the vertical limit. The filter will stop 
scaling when it reaches that horizontal limit. In that instance, the vertical dimension will not fill the page. 
If Stretch to fit page is off, there are two possibilities for how the bitmap will print: If the bitmap header 
contains its own resolution information (thereby setting its size in real-world units of measurement), the filter will
print the bitmap at that size. For example, if a bitmap is 450 pixels by 300 pixels, and the header specifies that 
its resolution is 100 dots per inch, it will print 4.5 inches by 3 inches, regardless of the resolution of the output 
device. (Many bitmap editing applications allow you to set this “internal” resolution.) If the bitmap header does 
not contain resolution information, the bitmap pixels are mapped directly to the output device pixels. So, using 
our 450 by 300 example, on a 300 dpi laser printer, the bitmap would print 1.5 inches by 1 inch.    For output 
devices with non-square pixels (where the dpi of the horizontal dimension doesn’t match the vertical), the 
bitmap pixels are directly mapped to the dimension of the smaller dpi number and stretched in the other 
dimension to accommodate the difference. The aspect ratio of the image is maintained on the page.
Note that Stretch to fit page works in both directions – expanding or shrinking the bitmap as needed. If you 
turn this option off and your bitmap is larger than the page, you will end up with a clipped image.
Center on page forces the image to print in the middle of the printable area of your page. If the device’s 
margins are not equal in the same dimension (for example, if the left margin is larger than the right), the larger 
margin is used on both sides. With Center on page off, the bitmap is placed in the upper left corner of the 
page.
Match page orientation to image
When enabled, this option automatically matches the orientation to the selected image. It then displays either a 
Portrait icon or a Landscape icon. If you prefer to set the orientation yourself for a selected document, clear 
the checkbox, click the Properties button and set the orientation you desire in the printer driver.
Minimum margin 
This option lets you set a margin around the image that’s larger than the printer’s hardware requires.    The units 
you enter into this box are in hundredths of an inch or hundredths of a centimeter (as indicated by the setting 
immediately below the box). So, for example, if you wanted to force a margin of 1 inch to accommodate a three-
hole punch, you would set Minimum margin to 100.    This setting affects the size of your output when Stretch 
to fit page is on, and increases the amount of clipping when you print a too-large bitmap with Stretch to fit 
page off. Setting a Minimum margin that’s smaller than the printer’s own margins will accomplish nothing – 
software cannot override hardware limitations.
Image Enhancement
If you are working with an 8-bit grayscale or 24-bit color image, the SuperQueue bitmap filters can perform 
automatic adjustments for both Lightness and Contrast. The filter examines each pixel of your image and 
creates an internal histogram – adding up the pixels that fall into each lightness value. Once this process is 
complete, the filter can modify the output settings dynamically to adjust for less-than-perfect images.
You can control whether or not the adjustments take place by checking or clearing the boxes next to Enhance 
lightness and Enhance contrast. The Preserve shadows and Preserve highlights controls work in 
conjunction with Enhance contrast. The numbers represent the percentage of color values that are close to the
extremeties (shadows and highlights) that the filter will preserve in your output. Decreasing either of these 
numbers increases the contrast of your output by allowing more output range to the mid-level input values and 
less to the extremities. Decreasing Preserve shadows causes more dark pixels to become black; decreasing 
Preserve highlights causes more light pixels to merge with white.
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PostScript filter specifications
The PostScript filter is Zenographics' ZScript module. It is a full-featured, level 2 PostScript language interpreter 
that translates PostScript page descriptions and Encapsulated PostScript (EPS) files into Windows GDI. This filter 
offers settings for Language Level, Accurate images, Accurate strokes, Accurate text clipping, and 
Ignore screens from PostScript file.
Language Level
Since PostScript level 1 is a subset of level 2, you should generally leave this setting on Level 2. All level 1 files 
and well-behaved level 2 files will work properly.
In rare instances, some level 2 files may cause errors during translation or printing. If this happens, switching to 
Level 1 may help get the job done. Well-written level 2 files are supposed to inquire about the level of the 
interpreter and dynamically accommodate the lower level interpreter. This workaround may result in some 
differences in the output, but these are generally not significant.
Accurate images/Accurate strokes
These settings are primarily for use with non-SuperDrivers. If you are using SuperDrivers, you can usually ignore 
these settings, leaving them in the off state.
There are inherent differences between the PostScript imaging model and the Windows GDI imaging model. 
SuperDrivers can compensate for some of these differences in ways that other Windows printer drivers cannot. 
Among these differences are scaling of color or grayscale bitmaps and rendering of lines.
With Accurate images off, ZScript lets the chosen printer driver scale the bitmap on its own. The results you 
get in both throughput and quality will vary depending on the driver. With Accurate images on, ZScript does 
the work of scaling the image and passing it along to the printer driver at the printer's native resolution. Use this 
option if your output displays either poor quality or imaging artifacts such as fine lines or unwanted patterns.
If the line widths, caps (line-end shapes), miters (shapes of corners), or dashed lines on your output are not 
accurate, try turning Accurate strokes on. With this setting, ZScript will translate lines into filled polygons of 
exactly the thickness and shape requested. Depending on the complexity of the drawing, this may add some 
processing time.
Accurate text clipping
In rare instances, you may have a piece of text that, as part of a design, is clipped (chopped off) in mid-
character. Most printer drivers recognize this clipping function and reproduce the effect accurately; some, 
however, do not. Accurate text clipping forces the ZScript filter to render clipped text as a bitmap, thereby 
ensuring accurate results. Depending on the complexity of the clipping, this may increase processing time. 
Unless you experience problems with clipped text, you should leave this option off.
Ignore screens from PostScript file
Some applications allow you to specify halftone screens within your PostScript file (for example, 133 line screen 
with a 45 degree screen angle). Such screens are usually needed only for pre-press imagesetting, not for desktop
printing.    
On your desktop printer, you may find that you get better looking results by using the halftoning (or dithering) 
that your printer uses by default. Also, depending on your printer driver and the complexity of the file, you may 
find that generating a custom screen adds processing time. If having exact line screen matching is not 
important, you can cause the filter to ignore the defined screens by turning this option on.
With this option off, any screens in the PostScript file will be imaged to the best ability of your printer and printer
driver. Be aware that setting a screen frequency that is too high for your hardware will result in dark and 
posterized output. Also note that some programs (such as Corel Ventura Publisher) let you specify screens for 
particular images without setting screen values for other page elements. In such a case, the graphics with 
unspecified screens will use your printer’s (or printer driver’s) default screen.
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About button
The About button brings up an informational dialog regarding the currently chosen filter. Included are the names
of some very talented programmers and the version number, the latter being useful if you should need to 
contact Zenographics for technical support.



Remote Processing
Remote Processing, in the Options menu, gives you a choice whether you want to process certain jobs locally
on the client workstation or remotely on the server. The choice applies to jobs that you add directly to 
SuperQueue (a bitmap or PostScript file).
It can pay to give some thought to where the job is processed. Network traffic might be an issue. Since Remote 
Processing puts the computing burden on the server, you may want to take into account the impact on the 
server PC. Also, with Remote Processing on, bitmaps and PostScript files are sent across the network in their 
native forms; a bitmap could be much larger or smaller than the amount of printer data it would generate.
Remote Processing is only available on the client if SuperQueue detects that the server PC also has 
SuperQueue and its print processor. You should also make sure that the server has all necessary filters installed.
Note: Remote Processing may not work in all client/server combinations of Windows 3.1,Windows 95, and 
Windows NT. When Remote Processing is not available, SuperQueue forces the client computer to do the 
rasterization and RAW printer data is sent over the network.



Starts printing documents in the printer queue.



Pauses printing of documents in the printer queue.



Click this to add supported data files into the printer queue. If files are to be printed right away, clear the Hold 
document(s)    (for Preview) checkbox.



Removes all documents from the printer queue. Documents created from a Windows application are also 
removed from disk. Documents added using Add Documents are not removed from disk. 



Establishes the selected printer as the default printer.



Click this to access printing options for the selected printer.



Click this to take a remote printer off line. Documents printed to it will be stored until you click it again. This 
command is available only for portable computers or for computers using a network printer. For local printers, 
use the Pause Printer command. 



Quit SuperQueue.



Holds a selected document. The document will not print until it is released.



Releases a selected held document and allows it to be printed.



Removes the selected document from the printer queue. Documents created from a Windows application are 
also removed from disk. Documents added using Add Document are not removed from disk. 



Moves a selected document to the top of the printer queue.



Moves a selected document up one place in the printer queue.



Moves a document down one place in the printer queue.



Moves a selected document to the bottom of the printer queue.



Lists the properties of the selected document.



Preview a document waiting to be printed. Only supported data file types may be previewed. Files must have 
been previously added using Add Documents with the Hold document(s) (for Preview) checkbox enabled.



Copies the selection from the message window and puts it on the clipboard.



Selects all the data in the message window.



Erases all the data in the message window.



Finds the specified text.



Shows or hides the Tool Bar.



Shows or hides the Status Bar.



Expands the queue area and displays documents (jobs) in the current queue.



Expands the message area and displays messages from the current queue. 



Refreshes queue display.



Arranges open printer windows in an overlapped fashion.



Arranges open printer windows in non-overlapped tiles.



Arranges minimized printer windows at the bottom of the SuperQueue window, especially useful when you have 
resized the window.



Displays program information, the SuperQueue version number and the copyright.



Displays the selected printer. If your cursor is over a tool bar button or menu choice, it describes the function of 
the button or choice instead.



Displays the status of the active printer.



Displays the number of documents in the printer queue.



Copies the current document to the clipboard. 



Opens a dialog that gives you access to filter management, including installing new filters, removing filters, and 
setting up filter options as defaults.



Opens a dialog that allows you to choose the font that displays queue and message information.



Turns the sound on or off.



When checked, sends documents to be rasterized and printed on a remote computer that is running 
SuperQueue. If SuperQueue is not available on the remote computer, do not check this option. The document 
will be rasterized locally and then sent on to be printed. The option is grayed and checked for NT workstations 
printing to other NT workstations. It is grayed and unchecked when you are printing locally.



Provides access to Help Topics.



SuperHelp displays tips and tricks for working with applications, devices and configurations. There is also 
information on how to contact Zenographics, a list of Frequently Asked Questions,    and helpful hints for 
troubleshooting.



Displays the installed filter libraries. 



Displays the filter and its associated data type(s) provided by the selected filter library.



Click this to install a new filter or to replace one you have previously removed. 



Click this to remove the selected filter.



Displays version number and copyright information about the selected filter.



Displays name of currently selected file and where it is located. 



 Click this to set filter options. You can also establish the options as the defaults. 



Lists the filters with extensions that are available to process documents. 



Saves all the changes you have made without closing the dialog box.



Opens the Help file for this dialog. 



When enabled, records filter messages in a log file. If messages have been logged, disabling this option gives 
you the option of keeping the messages or deleting all logs for all of your printers.



Allows you to view the contents of filter messages in log files created with Message Logging on. Will be grayed 
if there are no messages, or if you have not selected a Port tab.




